Linux内核20天内连爆两高危漏洞,一个命令又可以获得root权限

Linux内核漏洞最近几乎是一月一爆,在8月15号才爆了一个几乎通杀所有版本所有内核所有架构的内核漏洞;今天在学生返校的大喜日子里,竟然又爆了一个,通杀内核 2.6 < 2.6.19的所有32位Linux,算是google security team给祖国学生的礼物吧。
redhat已经发布补丁 RHSA-2009:1223 – Security Advisory  https://rhn.redhat.com/rhn/errata/details/Packages.do?eid=8969
rhel4打到2.6.9-89.0.9内核就没事了,RHEL5没时间验证,基本上yum升级一下可以解决问题。
sound180给出了一个不错的临时解决方案,详见评论的34楼 http://baoz.net/linux-localroot-no-patch-again/comment-page-1/#comment-1972
我想Linux内核的开发团队需要考虑引入微软的SDL安全开发生命周期以增强Linux内核的安全性,否则用户用着真是提心吊胆。
下面展示一下这个漏洞的威力:


别说我是标题党,的确是一个命令就可以获得root权限吧,在32位的RHEL4里基本上是百发百中,永不落空。
包子将密切关注RedHat、Debian、Ubuntu、Gentoo等主流发行版针对此漏洞的动向,出于对用户的保护,如果您需要了解和跟踪漏洞的细节,漏洞的重现方式和重现经验,敬请关注 http://baoz.net/linux-localroot-no-patch-again/ 以获取最新资讯

漏洞利用程序http://www.milw0rm.com/exploits/9542

上一篇: 黑客再爆Linux内核高危漏洞,一个命令可以攻击所有Linux系统   下一篇: The wxWidgets programming tutorial

提交疑问

回顶部