PostgreSQL 的PHP扩展安装错误

安装开发包

yum install postgresql-devel

编译PHP加上选项 --with-pdo-pgsql 时报以下错误

Unable to build the PDO PostgreSQL driver: libpq 7.4+ is required

 

查看库文件是否存在

 

rpm -ql postgresql-libs.x86_64   |grep libpq.so
/usr/lib64/libpq.so.5
/usr/lib64/libpq.so.5.2
 
不解,为啥还报错,先装PHP,再到ext/pdo_pgsql目录试着安装
/opt/php/bin/phpize 
./configure --with-php-config=/opt/php/bin/php-config 
make
make install
这样竟然可以通过了。

 

上一篇: debian6 搭建scribe   下一篇: Vim如何批量格式化代码,把4个空格替换为TAB

提交疑问

回顶部